Congress App password issue


I have an issue with the Congress App: it does not seem to handle well the password. I already had to remove and re-add my account details and create a new password twice. Next time I run the app and need password locked functionality (voting, freezing additional tokens etc), I am getting “incorrect password”. And I have to redo all the process of removing and re-adding the BOS account to the app.

Anybody knows anything about this?



Hi. i’ve passed this report to the devs. Thanks.


Thanks! Should I follow this post to see updates?


I’ll update this post, once the devs tell me something.


Hi berevoescu

I am dev team member.
I want to ask you something to understand your problem.
Does “re-add my account details” mean that you added your account with secrete key?
And What is the type of OS?




Yes, when this happens, I remove the account from the app and add it again using the secret key.
Next time I need to access a password protected functionality (vote, freeze some more tokens) I am getting the same error and I have to redo this process again.
I am using the MacOS version.



Is it a temporary case or is it going on?


I seems to be going on. It already happened three times in a row. I repeat: every time I need to access password protected functionality, I can only do it by deleting the account and re-adding it. Then, immediately after, I can access the voting or freezing functionality, I do it and next time I need access, I get the wrong password error. Last time, for example, I could not vote in time (for the second vote) because of it and I missed the deadline.

Note: I tested it on a second Mac I have and it is the same, so it does not seem to be related to a specific laptop.



Any news on this issue? Nobody else is experience this problem?